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Quick Start Guide for Farmbook 
 

The hardest part about using new software is getting started. 

This Quick Start Guide offers the quickest way to begin using Practical 

SystŜƳǎΩ Farmbook 
 
 

1 Quick Start Guide Icons 
 

  &  Learn a bit 
 

: Do a bit  
 

G Important information  
 

1.1 How to Install Farmbook 
 

There are two ways to install our programs: 

1.   Practical Systems website   www.practicalsystems.com.au 

Go to Customer Support > Customer Login. 

Login using your client ID and password. 

Install the full program or update your existing program  

 

 
 

 
2.   Install from the installation disk. 

8  Insert the Installation CD into your CD drive. 

The CD will run automatically and open the Installation Screen. 

You can install the desired program by following the prompts. 
 

 

http://www.practicalsystems.com.au/


 

1.2 Registration 
 

To register your purchased copy of Farmbook after installation, please phone Practical Systems on 

1800 624 688 for your unique unlock code. 
 

2 Finding help when you need it  
 

Help and electronic documents 
 
& A full manual can be found under Help > Manual you may print this manual. 

There is a search facility under Help > Contents this function allows for quick access to help on 

a specific subject.  

  

 

 
 

: Go to Help > Contents and follow the steps below 

 
 

 



2.1 On Screen Help 
&  To summon help from within a particular area of the program relevant to the screen 

you are on: 

: Press the F1 key or click the  button at the bottom right of the   

            screen. 

 

 
 
Example ς Help icon 
 

2.2 Demonstration Data 
&  The Demonstration Farm in Farmbook has been created so that you can start viewing, 

editing or manipulating information straight away.  This allows you enter practise information 

of your own, amend and delete items. - This helps you to explore and understand Farmbook 

: Go to File > Farms 

Select Demonstration Farm from the list  as pictured below 

 

 



2.3 Practical Systems Annual Subscription. 

&  Keeping your Annual Subscription up to date will ensure: 
 

ü  Your  software is  always  current.  Your  Annual  Subscription entitles  you to  program 
updates and upgrades. 

 

ü  Help is always at hand.  Annual Subscription provides you with telephone support during 
business hours (8.30am to 5.30pm Monday to Friday AEST) to help you through any queries 
or problems you may have. Use of this service is unlimited for your period of cover. 

 

Phone: 1800 624 688 

ü  You are provided with regular Practical Tip emails in the form of a step by step guide that 
enables you to get the most from your software. You will also be provided with newslett ers. 

ü A full index of Practical Tips is available for supported clients on our website. 
 

3 Getting Started 
 

G As mentioned previously, the hardest part about using new software is gett ing started. 

This guide illustrates a quick method of setting up your Farmbook 

G It is best to  setup as much as you can initially  and then you may add more information via 

ǘƘŜ ǎŜǘǳǇ ƳŜƴǳǎ ƻǊ άon the flyέ at a later date. We will discuss how this is done in section 

4.2 άCŀǊƳōƻƻƪ Setupέ  
 

 

3.1 What information do I required for setup? 

&  The following is a list of information you should have on hand to setup your Farmbook 
ü Property and paddock names their total area (Ha),Grazing area(Ha) and Arable(Ha) 
ü Product names,batch numbers and withholding periods 
ü Existing mob names and stock numbers. 

 

4 Setup 

4.1 Important Tips for setting up Farmbook 

 

Mapping Module 
If you have purchased the mapping module as an add on to Farmbook, please seek help from practical 

systems for setup procedure. 

 

Setup lists 
Work through the setup lists and initially enter as much data as you can.  This will speed up the data entry 

process.  After the initial setup you may add information through the setup lists as will as you go (add on-

the-fly)  See section 4.2 

 

Dates  
Dates are important to managing your Farmbook data and all events must be entered in the date 

sequence they occurred in.  If you follow the date protocol ȅƻǳ ǿƻƴΩǘ ŎƻƳŜ ǳnstuck, for example:  



 

ü When you are setting up the creation date for a  paddocks give yourself some room to move. Eg If 

you setup a paddock with a creation date of 1/01/2011 you will  not be able to record a treatment 

or stock movement to that paddock prior to its creation date. 

 

ü Avoid back dating events for your initial setup. Pick a starting date (preferably today) for all your 

Farmbook setup and activities .  

 
ü Ensure you record all events and movements in date order for example, if you physically 

performed a treatment on the 1 January 2011 and then  a paddock movement on the 5th January 

2011 make sure you record this sequence in your Farmbook in date order . Firstly enter your 

treatment in Farmbook (1 January 2011)and then enter your paddock movement.  (dated 5 January 

2011).  You will not be able to record the paddock movement first dated 5 January 2011 and then 

record a treatment on 1 January 2011 in this case. 

 

DSE updates 

 
DSE updates must only be carried out on mobs with paddock moments in place. ie: have all 

your paddock movements up to date before updating DSE values 

 

Mobs 

 
Enter a unique mob name for each mob.  Put some thought into how to name  your mobs.  A 

ƴŀƳŜΣ ǎǳŎƘ ŀǎ άǿŜŀƴŜǊǎέ ƻǊ άŎŀƭǾŜǎέ ǿƛƭƭ ƴƻǘ ōŜ ǾŜǊȅ ŘŜǎŎǊƛǇǘƛǾŜ ŦƻǊ ǎǳōǎŜǉǳŜƴǘ ȅŜŀǊǎΦ  ! 

ǎǳƎƎŜǎǘƛƻƴ ƛǎ ǘƻ ǳǎŜ ǘƘŜ ȅŜŀǊ ƻŦ ōƛǊǘƘ ŜƎΦ ά2011 Drop Ewesέ ƻǊ ά2011 Drop Cowsέ 

 

Beaware that once a mob has all its animals transferred out it will became INACTIVE and may NOT 

BE REUSED> 

 

Newly purchased animals may not be put directly into a mob this is already setup in Farmbook 

weather it be active or inactive.  If you are a trader a suggestion is to set up a mob that will always 

be on your property (eg. Heifer Mob or Ewe Mob)  This will effectively contain all the heifers or 

Ewes.  As you purchase a mob setup a new mob (eg. Armidale 1 (origin of stock purchase) or 

Armidale 1/01/2011.  When you have added the mob, you can then do a mob transfer to heifer 

mob(or its respective mob) as you move them to their relevant paddocks.  Effectively each new 

mob is only added as a way to bring in purchases, then they are transferred out again rendering 

them INACTIVE 

 

By only having one heifer or ewe mob, you are keeping things very simplistic, and giving all heifers 

or ewes etc. an average DSE rating, and an average dollar value.  Once you have this method in 



place you could start to split the mobs up a couple of ways (eg light heifers, medium heifers and 

heavy heifers). Animals could transfer through the different classes and be sold from the heavy 

mob.  The real benefit from doing this is it allows you to give different DSE ratings and dollar values 

to each mob. The important thing to remember here is that if you where to transfer all the animals 

out of a mob that mob would become INACTIVE. 

 

4.2 Farmbook Set up 

:  To begin your setup select the empty data set provided for your farm from the file menu 

(as pictured below) 

 

 
 

&  Properties, paddocks, mobs, products and events etc can be entered via the setup menus.  This 

information is then available in a drop-down list to save time typing speeding up data entry.  After 

the initial setup, you can add to the setups list in 2 ways. 

ü Via the Set up menu 

Or 

ü Via the use of the  άtƭǳǎ ōǳǘǘƻƴέ which can be found throughout the various data entry screens 

ŀǎ ȅƻǳ ǳǎŜ ǘƘŜ ǇǊƻƎǊŀƳΦ  ¢Ƙƛǎ ƛǎ ŎŀƭƭŜŘ άŀŘŘƛƴƎ ƻƴ ǘƘŜ ŦƭȅέΦ 

 

 

 



 
Example ς Adding on the fly 

G We suggest you set-up most of the initial information from the menu items.  This will speed-up 

event recording as you will have entered products etc.  Additions to the list can then be added 

on-the-fly as required. 

 

4.3 The Setup Menus 
 

Setup menus are accessed via setup (as below) 

 

 

 



G Each setup area follows the same basic rules and allows you to do the following: 

Add a new item 
&    Go to Setup and select the desired list (eg Setup > Paddocks) 

  Click on Add 

Enter your information (making your selection from the drop down list where              

applicable and adding-on ςthe fly if necessary).(see below) 

 

 
 

 

Edit an item 
&  Go to Setup and select the desired list and click on Edit or double click on the item. 

Modify the details as required, or make inactive for items you no longer want to appear in 

the drop down list. (see below) 

 

 
 



 

 

 

Delete an item 

G Go to Setup and select the desired list 

Select the item to be deleted 

Click on the delete icon (see below) 

 

 
 

 

 

G You cannot delete an item that still contains animals or treatments recorded against 

them. 

 



4.4 Suggested setup lists 

G The following sections outline suggested initial  setup lists.  Keep in mind any items can 

be added on-the-fly by using the  άtƭǳǎ button άƴŜȄǘ to the drop down list  or using the setup 

lists at any time.   

G Please refer to your full manual for setup of pasture varieties, cropping, harvesting, grain 

storage & sales, machinery, feed mixes and reports. 

 

4.5  Setting up your back up preferences 

G The first step in setting up is to setup your backup preferences. 

G Backing up is fundamental to managing your Farmbook data 

 

: Go to Setup  >  Backup Preferences and change your backup location from a: to your desired 

location. 

Select your preference by ticking or unticking boxes 

Click Close to save settings 

G You will be instructed to backup after you have completed your initial setup. 

Instructions for backing up are located in Part 5 of this Quick Start Guide 

 

G  If you would like set you back up location to a memory stick, you must insert the 

memory stick into your computer before selecting the browse option (yellow folder) 



4.6 Setup User Options 

 

&  There are several optional setup tabs under User Options.  At this stage the only optional field to 

fill out is the User tab.   

The Trading Name you enter will now show on all Farmbook reports as well as under the File 

menu  - File > Farms. 

 

:   Enter your trading name and User name (optional) and click OK. 

4.7 Setup Properties 

&  Every paddock must be linked to a property.  You may have as many properties as required. A 

property that has been disposed of or sold and is no longer required can be made inactive 



provided every paddock on that property is made inactive first.  In order to make a paddock 

inactive it must have no current mobs or crops in it. 

: Follow the steps below to add a Property 

 

4.8 Setup Paddocks 

&  As discussed every paddock must be linked to a property.  They can be linked to a    

management or grazing cell.  They can be further subdivided into as many  strips/blocks or plots as is 

necessary. 

: Follow the steps below to add a paddock 

 

 

 



4.9 Setup Livestock Types 

&  You may setup additional livestock types  by clicking on Setup > Livestock Types and enter the 

required information.  As with all setup areas you can also edit or delete livestock types. 

 

: Follow the steps below to add a livestock type 

 

 

4.10 Set up Livestock Classes (optional) 

&  Each mob of livestock can be allocated to a class.    

If you have purchased the feed budget module it would be compulsory to assign every mob     to a 

livestock class.  See feed budget manual under the help menu of Farmbook for setup details 

 

Example ς Livestock Classes 



4.11 Setup  Livestock Reporting Classes (optional) 

&  Livestock reporting classes are designed to allow you to group like livestock together for 

reconciliation reporting.  This is very useful if the mob, paddock, property groupings were 

insufficient to give you the subtotals you need within a reconciliation report. 

 

: To add a new reporting class open the Setup > Livestock Reporting Class menu. 

 

Example ς Livestock Reporting Classes 

4.12 Setup Mobs 

&  Mobs are a convenient method of organising animals, normally corresponding to a physical mob 

in a paddock.  A mob can, however, be split over several paddocks, and so can be used as a wider 

grouping method than a paddock. 

Mobs are either active or inactive. Active mobs are those that currently have animals in them.  

Inactive mobs are those that have no animals in them because they have been sold or transferred 

to another mob.  Inactive mobs cannot not be reused or deleted from Farmbook if any data has 

been entered against the mob. 

Mob movements can be tracked through your paddocks, generating useful data about the 

stocking rate for each paddock.  As well as being able to move a mob from one paddock to 

another, you can also merge them with another mob. 

G Refer to section 4 of this QǳƛŎƪ {ǘŀǊǘ DǳƛŘŜ ΥέLƳǇƻǊǘŀƴǘ ¢ƛǇǎ ŦƻǊ ǎŜǘǘƛƴƎ ǳǇ CŀǊƳōƻƻƪέ 

 

:  Adding an existing mob or a purchased mob  

Go to Setup > Mobs 

Click Add and fill out all the required information.  You will also be able to make your selection 

from various drop down boxes (as pictured below). 

There is also additional explanation notes below the picture to assist you. 

 



 
 

Note:  Make your paddock selection by clicking on the three-dot button.  You can also add a 

paddock as pictured below. 

 
 

 

 Definitions of source  

ü Existing.  Use this option for mobs that already exist on your property at the time of setting up 

Farmbook.  

ü Agist On-Farm.  Use this option to setup mobs that are being agisted onto your property. 

ü Purchased.  Use this option to setup newly purchased mobs of animals. Idealy these would be 

mobs purchased after the existing mobs have been setup. 

 

 

 

 

 

 



Entering a value :  

The =value is per stock unit..  The value is important because it is used as part of the livestock 

trading figures for the mob and subsequent gross margin analysis.  The value can and should be 

updated at regular intervals using the revalue function. 

 

Entering DSE rating 

Click on the DSE rating button and completer the individual DSE rating for the type of animals in 

this mob (average over the mob) You can source DSE tables from DPI or the internet if they are 

required. 

Farmbook is designed to continuously calculate the carrying capacity of you property.  To do this it 

needs accurate paddock sizes, and accurate number of stock being carried and as the most 

accurate as possible DSE rating for each of the animals possible throughout the year.  

 

More information on DSE  can be sourced from Help > Manual within your Farmbook program or 

by using the blue question mark (help icon) on the bottom left of the Add New Mob screen 

 

 
Example Mob Setup 

 

4.13 Setup Events 

&  In addition to the exiting list of events in Farmbook you may add your own events.  A 

suggestion is use a general description rather than a treatment. Eg.  Vaccinate rather then 5 in  1, 

Worm control rather then Drench and External Parasites rather than Pour-on)  However your 

products list, which you will setup later  should be specific. 

: Go to Setup > Events  

Add events as required. (see over) 



                  
 

4.14  Setup Product Groups. 
 

&  Products used on the farm can be optionally grouped into chemical or management 

groups.  This could be useful when managing herbicides or veterinary products for 

resistance. 

:  Go to Setup > Product Groups. 

               There is already a list setup which you could add to if required. 

 

 

4.15 Setup Products 

&  Products for use in animal, paddock, crop and machinery events can be entered for these 

events via dropdown lists.  Setting up these lists saves on data entry time. 

 

: Go to Setup > Products 

Click on Add and enter details as per product information. 

 

 



4.16 Setup Product Purchases 

&  You can record details of all products brought onto your farm. This must be kept if you are 

participating in any of the various Quality Assurance programs.  Even if you are not in a QA program 

the advantages are that once you record an event and apply a  product, Farmbook will calculate the 

cost per head and the total cost of the treatment to the selected animals. A full product inventory 

will be automatically maintained by Farmbook with the option of updating amounts on hand 

manually by using the stocktake facility.  This gives you flexibility allowing you to override the 

amount on hand for example updating amounts for products that have been  spilt or used for other 

purposes. 

: Go to Products > Product Purchases 

Click Add 

Enter the purchase details using the drop down lists where applicable or add-on the-fly 

Click OK 

 
 

 

 
 

 

 



5 Backing up 

&  As mentioned before backing up is fundamental to managing your Farmbook data 

Backing-up means taking a copy of your data. This is vital and cannot be over-emphasised. Data 
can be destroyed/corrupted for many reasons and you can be sure that the day will come when 

you will need to resort to a backup. Ideally, you should backup your data after every change.,  
The procedure is very simple: 
Backing-up means taking a copy of your data. This is vital and cannot be over-emphasised. Data 

can be destroyed/corrupted for many reasons and you can be sure that the day will come when 

you will need to resort to a backup.  The procedure is very simple: 

: Click on File/Backup Database menu option.  

Specify the location you want to backup to if different from the default you have set previously in 

your backup preferences screen.   

Note: The software will not allow you to backup into the same directory that Farmbook Premium has 

been installed on.  

 Enter a comment about the backup (optional). This could help you identify the backup set at some 

later stage if necessary.  

Note:  Click the Setup button if you wish to make changes to the backup settings/preferences.  

There are two phases to the backup, both of which will happen after clicking OK ( a status box will 

let you know what is happening) 

 You will be notified when the backup is complete. At this stage a file with the name made up of 

your client ID and the date will have been created on the specified drive/directory. (eg 

INDIV01031127-01.zip)  

(as pictured over) 



 

 

 

 

 

 



6 The Four Views 

There are four main data entry areas in Farmbook Premium, each corresponding with four icons on the 

opening splash screen ( as pictured below). 

 

 

The view screens allow you to 

ü Display a pictorial representation of the paddocks, mobs, crops and machinery setup in Farmbook. 

ü Select a property, cell, paddock, strip, mob, crop or machine to display a summary or detailed 

history of the selected item. 

ü Move mobs of animals around the paddocks. 

ü Open and close gates between paddocks. 

ü Sell a mob or portion of a mob. 

ü Transfer animals from one mob to another. 

ü Multiple select paddocks,strips, mobs, crops and machines to enter events. 

ü Change or delete selected events. 

 

:  To select a display of the data stored, and for data entry, against the relevant part of the database    

select the required view from the relevant icon. 

 


